// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[a-z]{3}_(ANEXO|(A|a)nexo)_[A-Za-z]{1,7}_[A-Z]{1}_[A-Z0-9]{2,5}...\.pdf").unwrap();
let string = "dge_ANEXO_II_F_TJ[1].pdf
dge_anexo_II_F_TJ[1].pdf
dge_Anexo_II_F_TJ[1].pdf
dge_aNEXO_II_F_TJ[1].pdf
dge_AneXo_II_F_TJ[1].pdf
dGe_AneXo_II_F_TJ[1].pdf // Erro \"G\"
dge_AneXo_Ii_j_TJ[1].pdf // Erro \"j\"
dge_AneXo_II_F_Tr[1].pdf // Erro \"r\"
dge_AneXo_II_F_TJ[TT].pdf // Erro \"TT\"
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}