#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*atewire_([^_]*)_.*"
Local $sString = "param0_test1_param1_affiliatewire_%nameID%_test2_param2_param3" & @CRLF & _
"param0_test1_param1_affiliatewire_name1_test2_param2_param3" & @CRLF & _
"param0_test1_param1_affiliatewire_name_test2_param2_param3" & @CRLF & _
"param0_test1_param1_affiliatewire_trollolo_test2_param2_param3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")