package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*atewire_([^_]*)_.*`)
var str = `param0_test1_param1_affiliatewire_%nameID%_test2_param2_param3
param0_test1_param1_affiliatewire_name1_test2_param2_param3
param0_test1_param1_affiliatewire_name_test2_param2_param3
param0_test1_param1_affiliatewire_trollolo_test2_param2_param3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}