re = /.*atewire_([^_]*)_.*/m
str = 'param0_test1_param1_affiliatewire_%nameID%_test2_param2_param3
param0_test1_param1_affiliatewire_name1_test2_param2_param3
param0_test1_param1_affiliatewire_name_test2_param2_param3
param0_test1_param1_affiliatewire_trollolo_test2_param2_param3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end