import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*atewire_([^_]*)_.*";
final String string = "param0_test1_param1_affiliatewire_%nameID%_test2_param2_param3\n"
+ "param0_test1_param1_affiliatewire_name1_test2_param2_param3\n"
+ "param0_test1_param1_affiliatewire_name_test2_param2_param3\n"
+ "param0_test1_param1_affiliatewire_trollolo_test2_param2_param3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}