package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?P<question>[\w '-]+)\s*(?P<suffix>\([\w '-]+\))?\s*(?::\s*(?P<options>[\w '-]+(?:,\s*[\w '-]+)*))?\s*\?\s*(?P<type>[\w '-]+)`)
var str = `Shirmer's Test (cm): Small Guy , Medium- Large , Extra-Large ? Text
Color: Yellow, Green, Red ? ListBox
Color ? ListBox`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}