$re = '/(?P<question>[\w \'-]+)\s*(?P<suffix>\([\w \'-]+\))?\s*(?::\s*(?P<options>[\w \'-]+(?:,\s*[\w \'-]+)*))?\s*\?\s*(?P<type>[\w \'-]+)/';
$str = 'Shirmer\'s Test (cm): Small Guy , Medium- Large , Extra-Large ? Text
Color: Yellow, Green, Red ? ListBox
Color ? ListBox';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);