re = /(?P<question>[\w '-]+)\s*(?P<suffix>\([\w '-]+\))?\s*(?::\s*(?P<options>[\w '-]+(?:,\s*[\w '-]+)*))?\s*\?\s*(?P<type>[\w '-]+)/
str = 'Shirmer\'s Test (cm): Small Guy , Medium- Large , Extra-Large ? Text
Color: Yellow, Green, Red ? ListBox
Color ? ListBox'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end