const regex = /(?P<question>[\w '-]+)\s*(?P<suffix>\([\w '-]+\))?\s*(?::\s*(?P<options>[\w '-]+(?:,\s*[\w '-]+)*))?\s*\?\s*(?P<type>[\w '-]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?P<question>[\\w \'-]+)\\s*(?P<suffix>\\([\\w \'-]+\\))?\\s*(?::\\s*(?P<options>[\\w \'-]+(?:,\\s*[\\w \'-]+)*))?\\s*\\?\\s*(?P<type>[\\w \'-]+)', 'g')
const str = `Shirmer's Test (cm): Small Guy , Medium- Large , Extra-Large ? Text
Color: Yellow, Green, Red ? ListBox
Color ? ListBox`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}