import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(0|10)*11(0|1)*";
final String string = "0100110\n"
+ "0111\n"
+ "00010011001\n"
+ "010101010101\n"
+ "0000000\n"
+ "00100000001\n"
+ "00110000001\n"
+ "00110000011\n"
+ "0000000\n"
+ "1000000\n"
+ "1100000\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}