$re = '/(0|10)*11(0|1)*/';
$str = '0100110
0111
00010011001
010101010101
0000000
00100000001
00110000001
00110000011
0000000
1000000
1100000
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);