const regex = /(0|10)*11(0|1)*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(0|10)*11(0|1)*', 'g')
const str = `0100110
0111
00010011001
010101010101
0000000
00100000001
00110000001
00110000011
0000000
1000000
1100000
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}