import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=@)[^:]+";
final String string = "pop3://abby@supremefill.com:ash9675@173.201.192.199:110\n"
+ "pop3://abby@jsnitro.com:littleman@173.201.192.199:110\n"
+ "smtp://tania@heritagecentre.ca:PCHta13@69.49.109.86:25\n"
+ "pop3://tania@heritagecentre.ca:PCHta13@69.49.109.86:110\n"
+ "pop3://abby@supremefill.com:ash9675@173.201.193.199:110\n"
+ "pop3://abby@jsnitro.com:littleman@173.201.193.199:110\n"
+ "smtp://liangyuan820211:820211ly520@202.108.6.242:25\n"
+ "pop3://smartinez@tornadobus.com:Sophia123@64.26.60.221:110";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}