const regex = /(?<=@)[^:]+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=@)[^:]+', 'g')
const str = `pop3://abby@supremefill.com:ash9675@173.201.192.199:110
pop3://abby@jsnitro.com:littleman@173.201.192.199:110
smtp://tania@heritagecentre.ca:PCHta13@69.49.109.86:25
pop3://tania@heritagecentre.ca:PCHta13@69.49.109.86:110
pop3://abby@supremefill.com:ash9675@173.201.193.199:110
pop3://abby@jsnitro.com:littleman@173.201.193.199:110
smtp://liangyuan820211:820211ly520@202.108.6.242:25
pop3://smartinez@tornadobus.com:Sophia123@64.26.60.221:110`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}