re = /(?<=@)[^:]+/
str = 'pop3://abby@supremefill.com:ash9675@173.201.192.199:110
pop3://abby@jsnitro.com:littleman@173.201.192.199:110
smtp://tania@heritagecentre.ca:PCHta13@69.49.109.86:25
pop3://tania@heritagecentre.ca:PCHta13@69.49.109.86:110
pop3://abby@supremefill.com:ash9675@173.201.193.199:110
pop3://abby@jsnitro.com:littleman@173.201.193.199:110
smtp://liangyuan820211:820211ly520@202.108.6.242:25
pop3://smartinez@tornadobus.com:Sophia123@64.26.60.221:110'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end