# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=@)[^:]+"
test_str = ("pop3://abby@supremefill.com:ash9675@173.201.192.199:110\n"
"pop3://abby@jsnitro.com:littleman@173.201.192.199:110\n"
"smtp://tania@heritagecentre.ca:PCHta13@69.49.109.86:25\n"
"pop3://tania@heritagecentre.ca:PCHta13@69.49.109.86:110\n"
"pop3://abby@supremefill.com:ash9675@173.201.193.199:110\n"
"pop3://abby@jsnitro.com:littleman@173.201.193.199:110\n"
"smtp://liangyuan820211:820211ly520@202.108.6.242:25\n"
"pop3://smartinez@tornadobus.com:Sophia123@64.26.60.221:110")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.