using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b\d{1,3}(?:,\d{3})*\.\d+\p{Zs}+SAR\b";
string input = @"(45.29 SAR ) or ( 4,523.88 SAR";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}