$re = '/\b\d{1,3}(?:,\d{3})*\.\d+\p{Zs}+SAR\b/';
$str = '(45.29 SAR ) or ( 4,523.88 SAR';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);