re = /\b\d{1,3}(?:,\d{3})*\.\d+\p{Zs}+SAR\b/
str = '(45.29 SAR ) or ( 4,523.88 SAR'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end