// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b\d{1,3}(?:,\d{3})*\.\d+\p{Zs}+SAR\b").unwrap();
let string = "(45.29 SAR ) or ( 4,523.88 SAR";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}