#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)<!--(?s:.*?)-->(*SKIP)(*F)|(<![^>]*[^\/]>)"
Local $sString = "<!--<p>some text here.</p>-->" & @CRLF & _
"<!This TAG>" & @CRLF & _
"<!-- <!Tag1><!Tag2><!Tag3> -->"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")