$re = '/<!--(?s:.*?)-->(*SKIP)(*F)|(<![^>]*[^\/]>)/i';
$str = '<!--<p>some text here.</p>-->
<!This TAG>
<!-- <!Tag1><!Tag2><!Tag3> -->';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);