package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)<!--(?s:.*?)-->(*SKIP)(*F)|(<![^>]*[^\/]>)`)
var str = `<!--<p>some text here.</p>-->
<!This TAG>
<!-- <!Tag1><!Tag2><!Tag3> -->`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}