re = /<!--(?s:.*?)-->(*SKIP)(*F)|(<![^>]*[^\/]>)/i
str = '<!--<p>some text here.</p>-->
<!This TAG>
<!-- <!Tag1><!Tag2><!Tag3> -->'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end