using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*function\s+(?:(?:\[((?:\s*\w+\s*,?)+)\]|(\w+))\s*=)?[ .]*(\w+)\s*(?:\(([^)]*)\))?";
string input = @"function loss = conductionLo7ss (self, Irms, m, DPF)
function [loss, arg2] = conductionLoss (self, Irms, m, DPF)
function loss = gf (self, Irms, m, DPF)
function loss = gf(self, Irms, m, DPF)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}