const regex = /^\s*function\s+(?:(?:\[((?:\s*\w+\s*,?)+)\]|(\w+))\s*=)?[ .]*(\w+)\s*(?:\(([^)]*)\))?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*function\\s+(?:(?:\\[((?:\\s*\\w+\\s*,?)+)\\]|(\\w+))\\s*=)?[ .]*(\\w+)\\s*(?:\\(([^)]*)\\))?', 'gm')
const str = `function loss = conductionLo7ss (self, Irms, m, DPF)
function [loss, arg2] = conductionLoss (self, Irms, m, DPF)
function loss = gf (self, Irms, m, DPF)
function loss = gf(self, Irms, m, DPF)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}