package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*function\s+(?:(?:\[((?:\s*\w+\s*,?)+)\]|(\w+))\s*=)?[ .]*(\w+)\s*(?:\(([^)]*)\))?`)
var str = `function loss = conductionLo7ss (self, Irms, m, DPF)
function [loss, arg2] = conductionLoss (self, Irms, m, DPF)
function loss = gf (self, Irms, m, DPF)
function loss = gf(self, Irms, m, DPF)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}