$re = '/^\s*function\s+(?:(?:\[((?:\s*\w+\s*,?)+)\]|(\w+))\s*=)?[ .]*(\w+)\s*(?:\(([^)]*)\))?/m';
$str = 'function loss = conductionLo7ss (self, Irms, m, DPF)
function [loss, arg2] = conductionLoss (self, Irms, m, DPF)
function loss = gf (self, Irms, m, DPF)
function loss = gf(self, Irms, m, DPF)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);