using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+\.?\d+";
string input = @"Array(The, value, of, your, profile, is, 234.2., You, have, potential, to, gain, 8.3, more.)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}