re = /\d+\.?\d+/
str = 'Array(The, value, of, your, profile, is, 234.2., You, have, potential, to, gain, 8.3, more.)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end