package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d+\.?\d+`)
var str = `Array(The, value, of, your, profile, is, 234.2., You, have, potential, to, gain, 8.3, more.)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}