$re = '/\d+\.?\d+/';
$str = 'Array(The, value, of, your, profile, is, 234.2., You, have, potential, to, gain, 8.3, more.)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);