#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?mx)" & @CRLF & _
"^(?:\+\d{1,2}\ )?" & @CRLF & _
"\(?\d{3}\)?" & @CRLF & _
"[\ \.-]" & @CRLF & _
"\d{3}" & @CRLF & _
"[\ \.-]" & @CRLF & _
"\d{4}"
Local $sString = "123-456-5555" & @CRLF & _
"(123) 222-1234" & @CRLF & _
"123 555 5555" & @CRLF & _
"123.777.7979" & @CRLF & _
"+91 (123) 455-6000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")