const regex = /(?mx)
^(?:\+\d{1,2}\ )?
\(?\d{3}\)?
[\ \.-]
\d{3}
[\ \.-]
\d{4}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?mx)
^(?:\\+\\d{1,2}\\ )?
\\(?\\d{3}\\)?
[\\ \\.-]
\\d{3}
[\\ \\.-]
\\d{4}', 'gm')
const str = `123-456-5555
(123) 222-1234
123 555 5555
123.777.7979
+91 (123) 455-6000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}