// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?mx)
^(?:\+\d{1,2}\ )?
\(?\d{3}\)?
[\ \.-]
\d{3}
[\ \.-]
\d{4}").unwrap();
let string = "123-456-5555
(123) 222-1234
123 555 5555
123.777.7979
+91 (123) 455-6000";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}