import re
regex = re.compile((r"(?mx)\n"
r"^(?:\+\d{1,2}\ )?\n"
r"\(?\d{3}\)?\n"
r"[\ \.-]\n"
r"\d{3}\n"
r"[\ \.-]\n"
r"\d{4}"), flags=re.MULTILINE)
test_str = ("123-456-5555\n"
"(123) 222-1234\n"
"123 555 5555\n"
"123.777.7979\n"
"+91 (123) 455-6000")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")