using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"tel:(?<phnum>[^\r\n;]+)";
string input = @"TEL;VALUE=uri;PREF=1;TYPE=\""voice,home\"":tel:+1-555-555-5555;ext=5555
TEL;VALUE=uri;PREF=1;TYPE=\""voice,home\"":tel:+1-555-555-5555;ext=5555
TEL;VALUE=uri;PREF=1;TYPE=\""voice,home\"":tel:+1-555-555-5555;ext=5555;";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}