$re = '/tel:(?<phnum>[^\r\n;]+)/m';
$str = 'TEL;VALUE=uri;PREF=1;TYPE=\\"voice,home\\":tel:+1-555-555-5555;ext=5555
TEL;VALUE=uri;PREF=1;TYPE=\\"voice,home\\":tel:+1-555-555-5555;ext=5555
TEL;VALUE=uri;PREF=1;TYPE=\\"voice,home\\":tel:+1-555-555-5555;ext=5555;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);