// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)tel:(?<phnum>[^\r\n;]+)").unwrap();
let string = "TEL;VALUE=uri;PREF=1;TYPE=\\\"voice,home\\\":tel:+1-555-555-5555;ext=5555
TEL;VALUE=uri;PREF=1;TYPE=\\\"voice,home\\\":tel:+1-555-555-5555;ext=5555
TEL;VALUE=uri;PREF=1;TYPE=\\\"voice,home\\\":tel:+1-555-555-5555;ext=5555;";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}