re = /tel:(?<phnum>[^\r\n;]+)/m
str = 'TEL;VALUE=uri;PREF=1;TYPE=\\"voice,home\\":tel:+1-555-555-5555;ext=5555
TEL;VALUE=uri;PREF=1;TYPE=\\"voice,home\\":tel:+1-555-555-5555;ext=5555
TEL;VALUE=uri;PREF=1;TYPE=\\"voice,home\\":tel:+1-555-555-5555;ext=5555;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end