#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\w+)\s*\((\w)\)\s*->\s*(\w+)"
Local $sString = "q0 (a) -> q1" & @CRLF & _
"q1 (b) -> q2"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)