using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+)\s*\((\w)\)\s*->\s*(\w+)";
string substitution = @"";
string input = @"q0 (a) -> q1
q1 (b) -> q2";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}