use strict;
my $str = 'q0 (a) -> q1
q1 (b) -> q2';
my $regex = qr/(\w+)\s*\((\w)\)\s*->\s*(\w+)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";