const regex = /(\w+)\s*\((\w)\)\s*->\s*(\w+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w+)\\s*\\((\\w)\\)\\s*->\\s*(\\w+)', 'gm')
const str = `q0 (a) -> q1
q1 (b) -> q2`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);