using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\s*\d+\s*\-\d+\s*,?|\s*\d+\s*,?)+$";
string input = @"1, 2, 3-5, 6, 8, 10-12-2
1, -5
1
1,2
1, 2-
1, 2-4
1-4,5
1-3,5-9
1-3,5,9,10-15
1, 2-10-2
1, 2-10-
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}