re = /^(\s*\d+\s*\-\d+\s*,?|\s*\d+\s*,?)+$/m
str = '1, 2, 3-5, 6, 8, 10-12-2
1, -5
1
1,2
1, 2-
1, 2-4
1-4,5
1-3,5-9
1-3,5,9,10-15
1, 2-10-2
1, 2-10-
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end