use strict;
my $str = '1, 2, 3-5, 6, 8, 10-12-2
1, -5
1
1,2
1, 2-
1, 2-4
1-4,5
1-3,5-9
1-3,5,9,10-15
1, 2-10-2
1, 2-10-
';
my $regex = qr/^(\s*\d+\s*\-\d+\s*,?|\s*\d+\s*,?)+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}