// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:(?:[1-9]|[1-9](?:\d{1,2})|10[0-2][0-3])(?:[KM])|(?:[1-9]|[1-3][0-9]|40)G)$").unwrap();
let string = "40G";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}