# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(idnotary=)[^\s&]*/$1replacement/;t' <<< "https://www.XXX.it/wp-json/custom-api/notary?title=Marina%20Rossi&wpcf-idnotary=089cy5Ra9zE=&wpcf-nome-notary=Marina....................
"