const regex = new RegExp('(idnotary=)[^\\s&]*', '')
const str = `https://www.XXX.it/wp-json/custom-api/notary?title=Marina%20Rossi&wpcf-idnotary=089cy5Ra9zE=&wpcf-nome-notary=Marina....................
`;
const subst = `$1replacement`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);